远程桌面发生身份验证错误,要求的函数不受支持

2018/5/15 7:28:27

远程桌面发生身份验证错误,要求的函数不受支持


远程桌面,出现身份验证错误,要求的函数不正确,这可能是由于CredSSP加密Oracle修正。

解决方案:

  1. 修改远程服务器的远程桌面安全级别为较不安全。

  2. 如果无法进入服务器修改,也可以在本地电脑修改注册表

  3. 在注册表里,自己手动建立 HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\ 位置新建项CredSSP\Parameters ,然后右边建立DWord的AllowEncryptionOracle,设置为2,重启即可。

  4. 第三种方式 

  5. 卸载更新KB4103718(适用于基于 x64 的系统的 Windows 7 月度安全质量汇总),重启Windows 7即可正常登录。
    或者使用微软官方建议修改本地组策略:
    计算机配置>管理模板>系统>凭据分配>加密Oracle修正 选择启用并选择易受攻击。
    易受攻击– 使用 CredSSP 的客户端应用程序将通过支持回退到不安全的版本使远程服务器遭受攻击,但使用 CredSSP 的服务将接受未修补的客户端。